Domino V10+ error message: ‘DB in use by another process’

On multiple customer environments running Domino on Windows Server 2016 you always receive the mentioned error when trying to delete a database.

One customer also had issues by accessing the FT index of databases after the Domino V10 migration.

First I thought that running the Domino servers in a clustered environment caused this issue but it´s much more easier:

Just exclude the Domino Data directory from being scanned by the Windows Defender. Afterwards everything´s running fine and you also are able to delete databases.

Right now I received the information from Uli that there´s a known bug in 10.0.1+ where DAOSMgr is not releasing database handles after running a “resync” or a “resync force”. But there´s a HotFix for 10.0.1 FP1 with SPR # GFALBCFAK3. So it seems that this fix is not included in 10.0.1 FP2 ( fix list ) because the fix was released just the day before FP2.

Requirements for new features in IBM Notes 10

There´s a small summary about “What´s needed for the new features in Notes/Domino V10 and V10.0.1”:

https://www-01.ibm.com/support/docview.wss?uid=ibm10872454

GENERAL FEATURES Standard or Basic config Minimum Notes version Minimum Domino version Minimum ODS level Minimum template version
Create a one-time signature at the time you reply to or forward a message . (Introduced in 10.0.1) Both V10 N/A N/A mail10.ntf
New workspace look Both V10 N/A N/A N/A
Custom color themes Standard V10 N/A N/A N/A
Application user interface enhancements Both V10 N/A N/A N/A
Touch screen on Windows Tablet Standard V10 N/A N/A N/A
Collapsible left navigator Standard V10.0.1 N/A N/A N/A
Quick contacts Both V10 N/A N/A mail10.ntf
pernames.ntf (10.0)
More accurate results when searching attachments Both V10 N/A N/A N/A
Updated import and export file types Both V10 N/A N/A N/A
Images in web tables look better when copied Both V10 N/A N/A N/A
Some preferences now enabled by default Both V10 N/A N/A mail10.ntf
MAIL FEATURES
By Sender mail view Both V10 N/A N/A mail10.ntf
Schedule when messages are delivered Both V10 V10 N/A mail10.ntf
Keep multiple forwarded messages separate Both V10 N/A N/A mail10.ntf
Second signature for replying and forwarding Both V10 N/A N/A mail10.ntf
Delegate can archive with editor access Both V10 N/A N/A mail10.ntf
Improved send mail errors and warnings Both V10 N/A N/A mail10.ntf
Larger Junk Mail Senders List Both V10 N/A N/A mai10.ntf
STARTTTLS support for Notes client SMTP connections Both V10 N/A N/A mail10.ntf
Upgrade more mail file folders at one time Both V10 N/A N/A mail10.ntf
CALENDAR FEATURES
Allow meeting attendees to invite others Both V10 N/A N/A mail10.ntf
Delegate calendar but not contacts Both V10 N/A N/A mail10.ntf
Apply Senders Colors to meetings Both V10 N/A N/A mail10.ntf
Add calendar categories and assign colors at the same time Both V10 N/A N/A mail10.ntf
Copy Into New – Calendar Entry copies online meeting details Both V10 N/A N/A mail10.ntf
Improved calendar interoperability with Outlook Both V10 N/A N/A mail10.ntf
Calendar overlay improvements Standard V10 N/A N/A N/A
Team calendar Both V10 N/A N/A mail10.ntf

Delete Person process fails on Delete Person in Domino Directory request

Regarding an IBM Technote there´s an issue when deleting a person from the Domino Directory via an AdminP request by selecting “Delete the mail database on the user’s home server” and the option “Delete mail replicas on all others server”.

There are 2 workaround mentioned in the TechNote:

1) Restore the person document from backup and re-delete them without checking the “other replicas” option or

2) Use the “Add Person” form action to add a ‘stub’ person (i.e. do not register the user).  Putting in the user name and mail file info (Domain, mail server, mail file) and then re-deleting them without checking the “other replicas” option.  Both options require that any other replicas of the mail file have to be deleted manually.